
11

1

EECS E6321 Tutorial 03
Standard cells, Virtuoso, Abstract Gen, 

and Silicon Smart

Mingoo Seok & Previous TAs



2

Semi-Custom Design Flow: Block-level
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Standard Cell Library
§ Collection of low-level blocks

§ Fundamental logic blocks (INV, NAND, DFF…)
§ Often Provided by the foundry and IP vendors

§ Standard cell library includes
§ SPICE netlist (for circuit-level simulation)
§ Symbols (for schematics @ Virtuoso)
§ Layout information (for APR or custom physical design)

§ Physical layout (*.gds file) + abstract view (*.lef file)
§ Verilog modules (for dynamic simulation)
§ Timing/power information (for Synthesis or Timing/power analysis)

§ Library characterization (*.lib/*.db file)

§ Visit - /courses/ee6350/pdk2025/tcbn65gplus
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.lib and .db files
§ Path: /courses/ee6350/pdk2025/tcbn65gplus/TSMCHOME/digital/Front_End/ 

timing_power_noise/CCS/tcbn65gplus_200a

§ Depending on conditions, different files are generated
§ *.lib/*.db have same information

§ .lib is human readable
§ .db is not
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Logic Families
§ How can we make digital circuits composed of different logic 

families?

§ We need to develop our own standard cells for logic synthesis 
and APR

Differential Cascode 
Voltage Switch (DCVS) Pass Gate Logic
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Library Development Flow

Abstract view 
generation

Transistor-level cell design
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Symbol
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§ Copy files from
§ /courses/ee6350/proj_2025Spring/ref/virtuoso
§ You don’t have to copy all subfolders, though

§ Another tutorial is on the EECS4321 website
§ http://www.bioee.ee.columbia.edu/courses/cad/html

To Start with…

http://www.bioee.ee.columbia.edu/courses/cad/html
http://www.bioee.ee.columbia.edu/courses/cad/html
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§ cds.lib includes the library

§ .cdsenv, .cdsinit contain the environmental setting for the virtuoso tool
§ run_virtuoso.source.sh

Cadence Virtuoso
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1. Select CIW → File → New → Library
2. Put your own library name
3. Choose ‘Attach to an existing technology library’ and click ‘OK’ button
4. Choose ‘tsmcN65’ at ‘Attach Library to Technology Library’ window

Make a New Library
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§ Please copy the ‘INVD0’ cell to your 
library
§ Cell position: 

/courses/ee6350/pdk2025/tcbn65gplus 
/TSMCHOME/digital/Back_End/oa/  
tcbn65gplus

§ pch: 260n/60n, nch: 195n/60n
§ Layer description

Inverter Layout

Layer Color Description

OD Red Active area (gate oxide and N+/P+ 
diffusion regions)

PO Blue Polysilicon line
NW Yellow N-Well

PP Purple P+ select (defines PMOS and p+ 
substrate contacts)

CO Green Metal contact
Mx - Metal layer (x = 1 - 9)
Vx - Via (x = 1 - 8)
PR 

Boundary White Boundary for placement & route

Metal1
(Blue)

OD
(Red)

PP
(Purple)

N-Well
(Yellow)

Poly
(blue)

M1 Label
(Blue)

PR Boundary
(White)

Contact
(Green)

Cell 
height

VDD

VSS
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§ When you set the power/gnd pin your schematic, you can use 
(1)inout pins or (2)vdd/gnd cells in ‘analogLib’
§ In case (2), the net names are ‘vdd!’, and ‘gnd!’
§ If the exclamation mark(!) is used as the part of the net name, this net 

is regarded as the global net
§ If you want to know about global nets in detail, please see 

‘Virtuoso_Inherited_Connections_Tutorial’ in CourseWorks

When Drawing Schematic

Case (1) Case (2)
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§ If you draw the layout of the cell which is not used as a 
standard cell, you don’t need to draw ‘PR Boundary’ layer

§ For LVS clean, you should create a label for the in/out nets
§ ‘Label’ and ‘Pin’ are different
§ ‘Pin’s used for creating abstract view

§ Recommend that pin boundary should be included in layer 
drawing

When Drawing Layout
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§ There exists more strict rules for our layout
§ Cell width/height, VDD/VSS rail
§ In addition, it is better to consider the position of other layers

§ Need to draw ‘PR Boundary’ layer precisely

Because We Draw the Standard Cell…
Ce

ll 
he

ig
ht

 
=

 1
.8

Origin
Cell width = multiple of 0.2

M1 height = 0.33OD height = 0.15 PP height = 0.21

PR Boundary

Horizontal PR Boundary aligns with the center of VDD/VSS rail
Vertical PR Boundary aligns with the boundary of VDD/VSS rail
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§ We need to change the contact position to avoid DRC violation
§ (TSMC 65nm) The contact should be located at center of 

every cell unit (0.2 µm × 1.8 µm)’s power rails 

Standard Cell Layout

INVD0 NR2D0
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1. In the layout view, select Calibre → 
nmDRC

2. When the DRC window opens up, 
choose the right ‘Rules file’

§ Sample located at 
/courses/ee6350/shared/calibre/DRC_20240408 
/calibre.core_28KAP.drc

3. Then, choose ‘Run Directory’ as 
(Virtuoso directory)/drc_run @ ‘Rules’ 
tab

§ If you leave it as your Virtuoso directory, the 
directory will be dirty due to DRC dump files

4. At ‘Inputs’ → ‘Layout Path’ tab, check 
‘Export from layout viewer’

5. Click ‘Run DRC’ button
*After running whole process, we can save this 
runset file (don’t need to repeat 2-4)

DRC Check

2.
3.

4.
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1. In the layout view, select Calibre → nmLVS
2. When the LVS window opens up, choose the right ‘Rules file’ 

§ Sample located at: 
/courses/ee6350/shared/calibre/pdk_cisl/lvs/calibre.lvs

3. Then, choose ‘Run Directory’ as (Virtuoso directory)/lvs_run @ ‘Rules’ tab
4. At ‘Inputs’ → ‘Layout Path’ tab, check ‘Export from layout viewer’
5. At ‘Inputs’ → ‘Source Path’ tab, check ‘Export from source viewer’
6. Click ‘Run LVS’ button
*After running whole process, we can save this runset file (don’t need to repeat 2-5)

LVS Check

4.

5.

2.
3.
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§ Please save your DRC/LVS runset files in your Virtuoso 
directory (e.g. runset.block, runset.top)

§ When you re-run DRC/LVS, you can select Calibre → Run 
nmDRC/LVS, and use the saved runset files

§ However, if you newly open Virtuoso, you have to configure 
the settings using the GUI 

DRC/LVS Notes

DRC Clean LVS Clean
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§ All cells have the same height
§ Horizontal VDD/VSS rails’ height should be the same as well

§ The cell width must be a multiple of the grid spacing
§ Filler cells should be included in your standard cell library

§ They provide continuity for your VDD/VSS rails, as well as for N-Well

Standard Cell Design Rule

Placing and Routing
VDD

VDD

VSS

1x 2x 4xFiller 1x

Filler2x 3x1x 1x

Grid 
spacing

Cell 
height
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§ Abstracts are simpler representations of the standard cells
§ Abstracts include information that is pertinent to the place-

and-route-tools only
§ i.e., metal and via layers

§ After creating abstract view, the *.lef file should be produced 
for the following steps
§ The output *.lef file contains the physical description of cells 

(dimension, location of pins and metals)
§ It can be fed into Automatic Place and Route (APR) such as Cadence 

Innovus

§ Before creating abstract views @ Layout window, select 
Edit → Advanced → Move origin, and change the origin as the 
bottom-left corner of the OUTLINE 

Abstract Generator
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@ Virtuoso
1. At layout window, select Tools → 

Create Pins From Labels
§ If you already created the pin while 

drawing layout, skip step 1)
§ Create pins only from ‘Metal label’ 

layers / ignore other layers
2. Set pins’ I/O type (Select the pin 

and press ‘Q’)
3. Select CIW → Tools → Abstract 

Generator
4. Change the settings as below

§ Library: Your library
§ Cell: Your cell
§ View: layout
§ Design Type: Core

5. Click ‘Load Options’ button 
6. Click ‘Generate Abstract’ button

How to Create Abstract Views
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1. Select CIW → File → Export → LEF
2. Change the settings as below

§ LEF File Name: Up to you 
§ Better to make a sub-directory (e.g., 

abstract_run) and save *.lef files in this 
directory

§ Library Name: Your library
§ Output Cell: Your cell (You can select multiple 

cells)
§ Output View: abstract

3. Check ‘No Technology’
4. Click ‘OK’ button
§ With our ‘abstract.options’ setting, 

layer OUTLINE defines the cell area
§ When you do the assignment, please 

select multiple output cells and 
generate one .lef file including the 
information of all cells

How to Export LEF File
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§ MACRO includes cell descriptions, cell dimensions, layout of pins and 
blockages

§ When you draw ‘PR boundry’ layer properly, you can achieve the 
correct ORIGIN and SIZE information

§ If needed, you can always make some edits on the file

Generated LEF File

Size

Pin info.

No OBS layers
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@ Abstract Gen
1. Type command $abstract at the terminal
2. Select File → Library → Open, and choose your library
3. Choose cells, select Cells → Move, and move then to ‘Core’

How to Create Abstract Views - Alternative

Pins

Extract

Abstract
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4. Click ‘Pins’ button, and change the settings at ‘Map’ tab
5. At ‘Boundary’ tab, put ‘OUTLINE’ in ‘Using geometry on layers’
6. Click ‘Run’ button

How to Create Abstract Views - Alternative
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7. Click ‘Extract’ button, and ‘Run’ button again in the new window
8. Click ‘Abstract’ button, and you can use either ‘Detailed’ or ‘Cover’ option 

at ‘Blockage’ tab
§ Detailed: Abstract knows about each metal paths in a block so they detour them in detail
§ Cover: Metal paths detour entire block

9. Click ‘Run’ button

How to Create Abstract Views - Alternative
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§ Abstract view only includes the metal information

How to Create Abstract Views - Alternative

OUTLINE
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§ Copy files from
§ /courses/ee6350/proj_2025Spring/ref/siliconsmart/example

To Start with…
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§ Synopsys SiliconSmart (SIS) is a characterization and 
modeling engine

§ The tool characterizes the timing, power, noise, and other 
critical characteristics of logic/sequential gates

§ Given a netlist for a cell, SIS runs the simulations and 
generates the library file (.lib) for the cell

§ The generated library can be used in Synthesis, PrimeTime, 
and compatible tools 

Synopsys SiliconSmart (SIS)
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§ Concurrent Current Source (CCS)
§ Maintains accuracy by capturing the full output waveforms under 

varying slew and load conditions
§ Uses a current source for driver modeling
§ Consists of current samples as a function of time
§ More accurate, but larger

§ Effective Current Source Model (ECSM)
§ Consists of voltage samples as a function of time
§ More efficient but less accurate / We will use this model

§ Non-Linear Delay Model (NLDM)
§ Uses a voltage source for driver modeling
§ It is simpler than the other two models

Library Timing Model
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Important files
§ run.tcl

§ Includes general setting and commands for SIS characterization flow
§ Defines list of cells to characterize

§ configure.tcl
§ Sets the operating condition: VDD, VSS, temperature, process
§ Defines parameters: Input slew, loading capacitance …

§ netlists/
§ You need to put your netlist file (.sp) and instance file (.inst) here to be 

characterized
§ lc.command

§ A script running Library Compiler to generate a .db file from the .lib file
§ You can find some sample .tcl files at ‘/tools/synopsys/silicon-

smart/P-2019.06/etc/examples/’
§ SiliconSmart command: $siliconsmart run.tcl
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§ First method
§ You can copy ‘(Cellname).src.net’ file from your ‘lvs_run’ directory and 

rename it to ‘(Cellname).sp’
§ I recommend to use *.src.net file instead of *.sp file in ‘lvs_run’ 

directory
§ Second method

1. At cell’s schematic window, select Launch → ADE L
2. At ADE window, select Setup → Simulator, and change Simulator as 

‘hspiceD’
3. Select Simulation →  Netlist → Create
4. You can find ‘netlist file in ~/simulation/(Cellname)/hspiceD/schemetic 

/netlist directory
5. Make this netlist as subckt, and rename it

§ At this PDK, the transistor instance name should be started 
with ‘x’ (Consider this when drawing the schematic in 
Virtuoso)

How to Generate .sp File



35

§ If you want to recharacterize the library in different conditions 
or add more cells at the library, please use the red box part

run.tcl

Put your .sp file in the netlist directory, 
also put .inst file if needed

Characterization directory
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run.tcl
1) In this case, because there is 
no reference library, we need to 
define our cell functionality 

2) Configure (based on configure.tcl)

3) Characterize

4) Model

inv.inst

If you want to know how to define 
the cell functionality, please see 
‘SiliconSmart_User_Guide’

Define the prefix of library name 
and output file name



37

configure.tcl

Define the operation condition

Technology model

Set the time resolution and slew 
rate range based on your FO4 delay
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§ When SiliconSmart generates the .lib file, it sweeps various 
parameters (e.g. slew rate, output capacitance…)

§ We should determine the reasonable range based on basic 
HSPICE simulation

configure.tcl

Index 2: output capacitance

Index 1: 
slew rate
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§ After executing SiliconSmart, all the detailed model, result, 
reports are generated in the results directory (char_dir in 
run.tcl)
§ Any naming is allowed, but recommend to use your technology, PVT 

setting and library timing model (e.g. ibm13_cmrf8sf_ecsm_tt_25_1p0)
§ Library Generator generates the .db file from .lib file

§ .db file is used for synthesis
§ Command: $lc_shell –xg_mode –f lc.command | tee lc.log
§ lc.command

§ At this lab session, you have to use this script after copying the 
generated *.lib file in ./lib directory

§ Please see run.sh or Makefile

Library Compiler
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Timing Library Information (.lib)

Power pin info.

Leakage power info.

Input specifications

Functional definition

Transition-specific 
energy info.

You can see transition-
specific delay info. below

Index 2: output capacitance

Index 1: 
slew rate

Library name
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End of Slides


